当前位置:首页 » 业界资讯 » 业界动态

Linux出现首个Wi-Fi缺陷 黑客可控制笔记本

...

    【赛迪网讯】4月16日消息,一款主要的Linux Wi-Fi驱动程序中被发现存在一个缺陷,它使黑客能够控制笔记本电脑,即使笔记本电脑没有在Wi-Fi网络上。
据Techworld.com网站报道称,目前,Linux平台上的Wi-Fi驱动程序还不太多,这显然是第一个可以被远程利用的Wi-Fi缺陷。据来自法国电信旗下Orange的研究人员劳伦特称,它影响被广泛使用的基于使用Atheros Wi-Fi芯片组的MadWi-Fi Linux内核设备驱动程序。劳伦特发现了该缺陷,并在上个月的Black Hat黑客会议上发布了相关信息。

    劳伦特表示,如果不以手工方式修正MadWi-Fi驱动程序,用户就存在受到攻击的可能性。在披露该缺陷前,他向MadWi-Fi开发团队通报了相关资料。MadWi-Fi开发团队已经发布了补丁软件。劳伦特说,但是,并非所有的Linux版本都集成了这一补丁软件。

    据劳伦特称,该内核堆栈溢出缺陷使黑客能够运行恶意代码,即使笔记本电脑没有登录在Wi-Fi网络上,该缺陷也可能为黑客所利用。

    Linux用户此前一直受困于Linux驱动程序的短缺,要求在Linux内核中支持无线网络。由于Wi-Fi网络上的Linux笔记本电脑较少,安全专家和黑客一直没有足够的时间来关注Linux驱动程序,但是,在内核一级处理远程数据在Linux上与其它操作系统上一样容易造成问题。(n106)

继续阅读
国内运营商拟开发Wi-Fi双模手机 盈利前景不看好
专家演示Gmail被劫过程 Wi-Fi存在漏洞
中电信在长三角开通Wi-Fi漫游 年内免费使用
发表评论

昵称:
最新评论
暂时没有评论!